re = /([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})/
str = '
Starting Nmap 6.47 ( http://nmap.org ) at 2015-05-26 22:43 ric
Initiating ARP Ping Scan at 22:43
Scanning 254 hosts [1 port/host]
Completed ARP Ping Scan at 22:43, 10.61s elapsed (254 total hosts)
Initiating Parallel DNS resolution of 254 hosts. at 22:50
Completed Parallel DNS resolution of
254 hosts. at 22:50, 16.50s elapsed
Nmap scan report for 192.168.1.0 [host down]
Nmap scan report for 192.168.1.2 [host down]
Nmap scan report for 192.168.1.3 [host down]
Nmap scan report for 192.168.1.4 [host down]
Nmap scan report for 192.168.1.5 [host down]
Nmap scan report for 192.168.1.7 [host down]
Nmap scan report for 192.168.1.8 [host down]
Nmap scan report for 192.168.1.9 [host down]
Nmap scan report for 192.168.1.10 [host down]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end