use strict;
my $str = '
Starting Nmap 6.47 ( http://nmap.org ) at 2015-05-26 22:43 ric
Initiating ARP Ping Scan at 22:43
Scanning 254 hosts [1 port/host]
Completed ARP Ping Scan at 22:43, 10.61s elapsed (254 total hosts)
Initiating Parallel DNS resolution of 254 hosts. at 22:50
Completed Parallel DNS resolution of
254 hosts. at 22:50, 16.50s elapsed
Nmap scan report for 192.168.1.0 [host down]
Nmap scan report for 192.168.1.2 [host down]
Nmap scan report for 192.168.1.3 [host down]
Nmap scan report for 192.168.1.4 [host down]
Nmap scan report for 192.168.1.5 [host down]
Nmap scan report for 192.168.1.7 [host down]
Nmap scan report for 192.168.1.8 [host down]
Nmap scan report for 192.168.1.9 [host down]
Nmap scan report for 192.168.1.10 [host down]';
my $regex = qr/([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}