import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3})";
final String string = "\n"
+ "Starting Nmap 6.47 ( http://nmap.org ) at 2015-05-26 22:43 ric\n"
+ "Initiating ARP Ping Scan at 22:43\n"
+ "Scanning 254 hosts [1 port/host]\n"
+ "Completed ARP Ping Scan at 22:43, 10.61s elapsed (254 total hosts)\n"
+ "Initiating Parallel DNS resolution of 254 hosts. at 22:50\n"
+ "Completed Parallel DNS resolution of \n\n"
+ "254 hosts. at 22:50, 16.50s elapsed\n"
+ "Nmap scan report for 192.168.1.0 [host down]\n"
+ "Nmap scan report for 192.168.1.2 [host down]\n"
+ "Nmap scan report for 192.168.1.3 [host down]\n"
+ "Nmap scan report for 192.168.1.4 [host down]\n"
+ "Nmap scan report for 192.168.1.5 [host down]\n"
+ "Nmap scan report for 192.168.1.7 [host down]\n"
+ "Nmap scan report for 192.168.1.8 [host down]\n"
+ "Nmap scan report for 192.168.1.9 [host down]\n"
+ "Nmap scan report for 192.168.1.10 [host down]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}