#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})"
Local $sString = "" & @CRLF & _
"Starting Nmap 6.47 ( http://nmap.org ) at 2015-05-26 22:43 ric" & @CRLF & _
"Initiating ARP Ping Scan at 22:43" & @CRLF & _
"Scanning 254 hosts [1 port/host]" & @CRLF & _
"Completed ARP Ping Scan at 22:43, 10.61s elapsed (254 total hosts)" & @CRLF & _
"Initiating Parallel DNS resolution of 254 hosts. at 22:50" & @CRLF & _
"Completed Parallel DNS resolution of " & @CRLF & _
"" & @CRLF & _
"254 hosts. at 22:50, 16.50s elapsed" & @CRLF & _
"Nmap scan report for 192.168.1.0 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.2 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.3 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.4 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.5 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.7 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.8 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.9 [host down]" & @CRLF & _
"Nmap scan report for 192.168.1.10 [host down]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")