# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3})"
test_str = ("\n"
"Starting Nmap 6.47 ( http://nmap.org ) at 2015-05-26 22:43 ric\n"
"Initiating ARP Ping Scan at 22:43\n"
"Scanning 254 hosts [1 port/host]\n"
"Completed ARP Ping Scan at 22:43, 10.61s elapsed (254 total hosts)\n"
"Initiating Parallel DNS resolution of 254 hosts. at 22:50\n"
"Completed Parallel DNS resolution of \n\n"
"254 hosts. at 22:50, 16.50s elapsed\n"
"Nmap scan report for 192.168.1.0 [host down]\n"
"Nmap scan report for 192.168.1.2 [host down]\n"
"Nmap scan report for 192.168.1.3 [host down]\n"
"Nmap scan report for 192.168.1.4 [host down]\n"
"Nmap scan report for 192.168.1.5 [host down]\n"
"Nmap scan report for 192.168.1.7 [host down]\n"
"Nmap scan report for 192.168.1.8 [host down]\n"
"Nmap scan report for 192.168.1.9 [host down]\n"
"Nmap scan report for 192.168.1.10 [host down]")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.