import Foundation
let pattern = #"\A[A-Za-z]+(?:\(-?[1-9][0-9]*\))?(?:\.[A-Za-z]+(?:\(-?[1-9][0-9]*\))?)*\z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"m(2).s(-1)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}