re = /\A[A-Za-z]+(?:\(-?[1-9][0-9]*\))?(?:\.[A-Za-z]+(?:\(-?[1-9][0-9]*\))?)*\z/
str = 'm(2).s(-1)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end