using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\A[A-Za-z]+(?:\(-?[1-9][0-9]*\))?(?:\.[A-Za-z]+(?:\(-?[1-9][0-9]*\))?)*\z";
string input = @"m(2).s(-1)";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}