const regex = /\A[A-Za-z]+(?:\(-?[1-9][0-9]*\))?(?:\.[A-Za-z]+(?:\(-?[1-9][0-9]*\))?)*\z/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A[A-Za-z]+(?:\\(-?[1-9][0-9]*\\))?(?:\\.[A-Za-z]+(?:\\(-?[1-9][0-9]*\\))?)*\\z', '')
const str = `m(2).s(-1)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}