#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\A[A-Za-z]+(?:\(-?[1-9][0-9]*\))?(?:\.[A-Za-z]+(?:\(-?[1-9][0-9]*\))?)*\z"
Local $sString = "m(2).s(-1)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")