re = /^(((http:|https:)+(\/\/|\\\\))|)+([0-9\w+]+\.+[\w+]{2,15})/
str = 'sdwsasdjfasdfjasdfdfsfsefsdflkasjdflkashdlfahwle.we'
# Print the match result
str.match(re) do |match|
puts match.to_s
end