using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(((http:|https:)+(\/\/|\\\\))|)+([0-9\w+]+\.+[\w+]{2,15})";
string input = @"sdwsasdjfasdfjasdfdfsfsefsdflkasjdflkashdlfahwle.we";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}