$re = '/^(((http:|https:)+(\/\/|\\\\\\\\))|)+([0-9\w+]+\.+[\w+]{2,15})/';
$str = 'sdwsasdjfasdfjasdfdfsfsefsdflkasjdflkashdlfahwle.we';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);