const regex = /^(((http:|https:)+(\/\/|\\\\))|)+([0-9\w+]+\.+[\w+]{2,15})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(((http:|https:)+(\\\/\\\/|\\\\\\\\))|)+([0-9\\w+]+\\.+[\\w+]{2,15})', '')
const str = `sdwsasdjfasdfjasdfdfsfsefsdflkasjdflkashdlfahwle.we`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}