package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(((http:|https:)+(\/\/|\\\\))|)+([0-9\w+]+\.+[\w+]{2,15})`)
var str = `sdwsasdjfasdfjasdfdfsfsefsdflkasjdflkashdlfahwle.we`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}