import Foundation
let pattern = #"^(([0-9]+) x )*([^@\v]+)(@ ([0-9]+\.[0-9]+)\/(.*))*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
3 x Private Full Cabinet 42U Setup Fee @ 500.00/each
3 x Private Full Cabinet 42U (02/13/2020 - 03/12/2020) @ 500.00/each
3 x Primary Circuit Setup Fee @ 300.00/each
3 x Primary Circuit (02/13/2020 - 03/12/2020)
Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 325.00/each
3 x Redundant Circuit Setup Fee @ 300.00/each
3 x Redundant Circuit (02/13/2020 - 03/12/2020)
Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 81.25/each
DIA (02/13/2020 - 03/12/2020)
Carrier Neutral Blend: 100Mbps Flat Rate
IPv4 Setup Fee
IPv4 (02/13/2020 - 03/12/2020) Network: /29
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)