# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(([0-9]+) x )*([^@\v]+)(@ ([0-9]+\.[0-9]+)\/(.*))*$"
test_str = ("3 x Private Full Cabinet 42U Setup Fee @ 500.00/each\n"
"3 x Private Full Cabinet 42U (02/13/2020 - 03/12/2020) @ 500.00/each\n"
"3 x Primary Circuit Setup Fee @ 300.00/each\n"
"3 x Primary Circuit (02/13/2020 - 03/12/2020)\n"
"Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 325.00/each\n"
"3 x Redundant Circuit Setup Fee @ 300.00/each\n"
"3 x Redundant Circuit (02/13/2020 - 03/12/2020)\n"
"Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 81.25/each\n"
"DIA (02/13/2020 - 03/12/2020)\n"
"Carrier Neutral Blend: 100Mbps Flat Rate\n"
"IPv4 Setup Fee\n"
"IPv4 (02/13/2020 - 03/12/2020) Network: /29")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.