#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([0-9]+) x )*([^@\v]+)(@ ([0-9]+\.[0-9]+)\/(.*))*$"
Local $sString = "3 x Private Full Cabinet 42U Setup Fee @ 500.00/each" & @CRLF & _
"3 x Private Full Cabinet 42U (02/13/2020 - 03/12/2020) @ 500.00/each" & @CRLF & _
"3 x Primary Circuit Setup Fee @ 300.00/each" & @CRLF & _
"3 x Primary Circuit (02/13/2020 - 03/12/2020)" & @CRLF & _
"Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 325.00/each" & @CRLF & _
"3 x Redundant Circuit Setup Fee @ 300.00/each" & @CRLF & _
"3 x Redundant Circuit (02/13/2020 - 03/12/2020)" & @CRLF & _
"Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 81.25/each" & @CRLF & _
"DIA (02/13/2020 - 03/12/2020)" & @CRLF & _
"Carrier Neutral Blend: 100Mbps Flat Rate" & @CRLF & _
"IPv4 Setup Fee" & @CRLF & _
"IPv4 (02/13/2020 - 03/12/2020) Network: /29"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")