re = /^(([0-9]+) x )*([^@\v]+)(@ ([0-9]+\.[0-9]+)\/(.*))*$/m
str = '3 x Private Full Cabinet 42U Setup Fee @ 500.00/each
3 x Private Full Cabinet 42U (02/13/2020 - 03/12/2020) @ 500.00/each
3 x Primary Circuit Setup Fee @ 300.00/each
3 x Primary Circuit (02/13/2020 - 03/12/2020)
Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 325.00/each
3 x Redundant Circuit Setup Fee @ 300.00/each
3 x Redundant Circuit (02/13/2020 - 03/12/2020)
Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 81.25/each
DIA (02/13/2020 - 03/12/2020)
Carrier Neutral Blend: 100Mbps Flat Rate
IPv4 Setup Fee
IPv4 (02/13/2020 - 03/12/2020) Network: /29'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end