using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([0-9]+) x )*([^@\v]+)(@ ([0-9]+\.[0-9]+)\/(.*))*$";
string input = @"3 x Private Full Cabinet 42U Setup Fee @ 500.00/each
3 x Private Full Cabinet 42U (02/13/2020 - 03/12/2020) @ 500.00/each
3 x Primary Circuit Setup Fee @ 300.00/each
3 x Primary Circuit (02/13/2020 - 03/12/2020)
Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 325.00/each
3 x Redundant Circuit Setup Fee @ 300.00/each
3 x Redundant Circuit (02/13/2020 - 03/12/2020)
Circuit Type: 0U 20A 120V 1Ø 2.4kW @ 81.25/each
DIA (02/13/2020 - 03/12/2020)
Carrier Neutral Blend: 100Mbps Flat Rate
IPv4 Setup Fee
IPv4 (02/13/2020 - 03/12/2020) Network: /29";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}