use strict;
my $str = 'https://twitter.com/settings/account
https://twitter.com/messages
https://twitter.com/notifications
https://twitter.com/donate4_fun
https://twitter.com/donate4_fun/zxcqwe
https://twitter.com/nbryskin
https://twitter.com/jack
https://twitter.com/i/asd';
my $regex = qr/^https:\/\/twitter.com\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\/)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}