#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https:\/\/twitter.com\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\/)"
Local $sString = "https://twitter.com/settings/account" & @CRLF & _
"https://twitter.com/messages" & @CRLF & _
"https://twitter.com/notifications" & @CRLF & _
"https://twitter.com/donate4_fun" & @CRLF & _
"https://twitter.com/donate4_fun/zxcqwe" & @CRLF & _
"https://twitter.com/nbryskin" & @CRLF & _
"https://twitter.com/jack" & @CRLF & _
"https://twitter.com/i/asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")