const regex = /^https:\/\/twitter.com\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/twitter.com\\\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\\\/)', 'gm')
const str = `https://twitter.com/settings/account
https://twitter.com/messages
https://twitter.com/notifications
https://twitter.com/donate4_fun
https://twitter.com/donate4_fun/zxcqwe
https://twitter.com/nbryskin
https://twitter.com/jack
https://twitter.com/i/asd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}