using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https:\/\/twitter.com\/(?!messages|notifications|settings)[a-zA-Z0-9_]{4,15}($|\/)";
string input = @"https://twitter.com/settings/account
https://twitter.com/messages
https://twitter.com/notifications
https://twitter.com/donate4_fun
https://twitter.com/donate4_fun/zxcqwe
https://twitter.com/nbryskin
https://twitter.com/jack
https://twitter.com/i/asd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}