// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\"(.*)\")"#).unwrap();
let string = "*e UserInterface Extensions Event Changed Signal: \"togglebutton:on\"
*e UserInterface Extensions Event Changed Signal: \"togglebutton:off\"
*e UserInterface Extensions Event Pressed Signal: \"slider\"
*e UserInterface Extensions Event Changed Signal: \"slider:32\"
*e UserInterface Extensions Event Changed Signal: \"slider:68\"
*e UserInterface Extensions Event Released Signal: \"slider:68\"
*e UserInterface Extensions Event Pressed Signal: \"spinner:decrement\"
*e UserInterface Extensions Event Released Signal: \"spinner:decrement\"
*e UserInterface Extensions Event Clicked Signal: \"spinner:decrement\"
*e UserInterface Extensions Event Pressed Signal: \"button\"
*e UserInterface Extensions Event Released Signal: \"button\"
*e UserInterface Extensions Event Clicked Signal: \"button\"
*e UserInterface Extensions Event Pressed Signal: \"symbol\"
*e UserInterface Extensions Event Released Signal: \"symbol\"
*e UserInterface Extensions Event Clicked Signal: \"symbol\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}