using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\""(.*)\"")";
string input = @"*e UserInterface Extensions Event Changed Signal: ""togglebutton:on""
*e UserInterface Extensions Event Changed Signal: ""togglebutton:off""
*e UserInterface Extensions Event Pressed Signal: ""slider""
*e UserInterface Extensions Event Changed Signal: ""slider:32""
*e UserInterface Extensions Event Changed Signal: ""slider:68""
*e UserInterface Extensions Event Released Signal: ""slider:68""
*e UserInterface Extensions Event Pressed Signal: ""spinner:decrement""
*e UserInterface Extensions Event Released Signal: ""spinner:decrement""
*e UserInterface Extensions Event Clicked Signal: ""spinner:decrement""
*e UserInterface Extensions Event Pressed Signal: ""button""
*e UserInterface Extensions Event Released Signal: ""button""
*e UserInterface Extensions Event Clicked Signal: ""button""
*e UserInterface Extensions Event Pressed Signal: ""symbol""
*e UserInterface Extensions Event Released Signal: ""symbol""
*e UserInterface Extensions Event Clicked Signal: ""symbol""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}