import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\\\"(.*)\\\")";
final String string = "*e UserInterface Extensions Event Changed Signal: \"togglebutton:on\"\n"
+ "*e UserInterface Extensions Event Changed Signal: \"togglebutton:off\"\n"
+ "*e UserInterface Extensions Event Pressed Signal: \"slider\"\n"
+ "*e UserInterface Extensions Event Changed Signal: \"slider:32\"\n"
+ "*e UserInterface Extensions Event Changed Signal: \"slider:68\"\n"
+ "*e UserInterface Extensions Event Released Signal: \"slider:68\"\n"
+ "*e UserInterface Extensions Event Pressed Signal: \"spinner:decrement\"\n"
+ "*e UserInterface Extensions Event Released Signal: \"spinner:decrement\"\n"
+ "*e UserInterface Extensions Event Clicked Signal: \"spinner:decrement\"\n"
+ "*e UserInterface Extensions Event Pressed Signal: \"button\"\n"
+ "*e UserInterface Extensions Event Released Signal: \"button\"\n"
+ "*e UserInterface Extensions Event Clicked Signal: \"button\"\n"
+ "*e UserInterface Extensions Event Pressed Signal: \"symbol\"\n"
+ "*e UserInterface Extensions Event Released Signal: \"symbol\"\n"
+ "*e UserInterface Extensions Event Clicked Signal: \"symbol\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}