#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\"(.*)\")"
Local $sString = "*e UserInterface Extensions Event Changed Signal: "togglebutton:on"" & @CRLF & _
"*e UserInterface Extensions Event Changed Signal: "togglebutton:off"" & @CRLF & _
"*e UserInterface Extensions Event Pressed Signal: "slider"" & @CRLF & _
"*e UserInterface Extensions Event Changed Signal: "slider:32"" & @CRLF & _
"*e UserInterface Extensions Event Changed Signal: "slider:68"" & @CRLF & _
"*e UserInterface Extensions Event Released Signal: "slider:68"" & @CRLF & _
"*e UserInterface Extensions Event Pressed Signal: "spinner:decrement"" & @CRLF & _
"*e UserInterface Extensions Event Released Signal: "spinner:decrement"" & @CRLF & _
"*e UserInterface Extensions Event Clicked Signal: "spinner:decrement"" & @CRLF & _
"*e UserInterface Extensions Event Pressed Signal: "button"" & @CRLF & _
"*e UserInterface Extensions Event Released Signal: "button"" & @CRLF & _
"*e UserInterface Extensions Event Clicked Signal: "button"" & @CRLF & _
"*e UserInterface Extensions Event Pressed Signal: "symbol"" & @CRLF & _
"*e UserInterface Extensions Event Released Signal: "symbol"" & @CRLF & _
"*e UserInterface Extensions Event Clicked Signal: "symbol""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")