package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\*e UserInterface Extensions Event (Pressed|Released|Clicked|Changed) Signal: (\"(.*)\")`)
var str = `*e UserInterface Extensions Event Changed Signal: "togglebutton:on"
*e UserInterface Extensions Event Changed Signal: "togglebutton:off"
*e UserInterface Extensions Event Pressed Signal: "slider"
*e UserInterface Extensions Event Changed Signal: "slider:32"
*e UserInterface Extensions Event Changed Signal: "slider:68"
*e UserInterface Extensions Event Released Signal: "slider:68"
*e UserInterface Extensions Event Pressed Signal: "spinner:decrement"
*e UserInterface Extensions Event Released Signal: "spinner:decrement"
*e UserInterface Extensions Event Clicked Signal: "spinner:decrement"
*e UserInterface Extensions Event Pressed Signal: "button"
*e UserInterface Extensions Event Released Signal: "button"
*e UserInterface Extensions Event Clicked Signal: "button"
*e UserInterface Extensions Event Pressed Signal: "symbol"
*e UserInterface Extensions Event Released Signal: "symbol"
*e UserInterface Extensions Event Clicked Signal: "symbol"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}