re = /^(CLI telnet).*(Rd ping)$/
str = 'CLI telnet ::1 45609xcvcxvvwsesf<esqgQAge<q f<q082 Rd ping'
# Print the match result
str.match(re) do |match|
puts match.to_s
end