using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(CLI telnet).*(Rd ping)$";
string input = @"CLI telnet ::1 45609xcvcxvvwsesf<esqgQAge<q f<q082 Rd ping";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}