package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(CLI telnet).*(Rd ping)$`)
var str = `CLI telnet ::1 45609xcvcxvvwsesf<esqgQAge<q f<q082 Rd ping`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}