const regex = /^(CLI telnet).*(Rd ping)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(CLI telnet).*(Rd ping)$', '')
const str = `CLI telnet ::1 45609xcvcxvvwsesf<esqgQAge<q f<q082 Rd ping`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}