#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(CLI telnet).*(Rd ping)$"
Local $sString = "CLI telnet ::1 45609xcvcxvvwsesf<esqgQAge<q f<q082 Rd ping"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")