# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"I'm logged in as (?:a\s|an\s)(?:\"([^\"]*)\"\s)?(?:user|customer)\s(?:(?:for[\sa\s|\san\s]?)(?:\"([^\"]*)\"\s))?"
test_str = ("Given I'm logged in as a user for a \"password change\" to eCommerce\n"
"Given I'm logged in as an \"inactive\" user for a \"password change\" to eCommerce\n"
"Given I'm logged in as an \"inactive\" user to eCommerce\n"
"Given I'm logged in as a \"simple\" user to eCommerce\n"
"Given I'm logged in as a user in a \"shared\" account to eCommerce\n"
"Given I'm logged in as a user in a \"bucket\" account to eCommerce\n"
"Given I'm logged in as a user for \"email notification tests\" to eCommerce\n"
"Given I'm logged in as a user with \"cs admin and sales admin\" roles to eCommerce\n"
"Given I'm logged in as a user with \"cs & bb\" roles for a \"passwd change\" to eCommerce\n"
"Given I'm logged in as an \"inactive\" user with \"cs admin\" roles to eCommerce\n\n"
"Given I'm logged in as \"ducking\" user with \"ducking\" roles to eCommerce\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.