import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "I'm logged in as (?:a\\s|an\\s)(?:\"([^\"]*)\"\\s)?(?:user|customer)\\s(?:(?:for[\\sa\\s|\\san\\s]?)(?:\"([^\"]*)\"\\s))?";
final String string = "Given I'm logged in as a user for a \"password change\" to eCommerce\n"
+ "Given I'm logged in as an \"inactive\" user for a \"password change\" to eCommerce\n"
+ "Given I'm logged in as an \"inactive\" user to eCommerce\n"
+ "Given I'm logged in as a \"simple\" user to eCommerce\n"
+ "Given I'm logged in as a user in a \"shared\" account to eCommerce\n"
+ "Given I'm logged in as a user in a \"bucket\" account to eCommerce\n"
+ "Given I'm logged in as a user for \"email notification tests\" to eCommerce\n"
+ "Given I'm logged in as a user with \"cs admin and sales admin\" roles to eCommerce\n"
+ "Given I'm logged in as a user with \"cs & bb\" roles for a \"passwd change\" to eCommerce\n"
+ "Given I'm logged in as an \"inactive\" user with \"cs admin\" roles to eCommerce\n\n"
+ "Given I'm logged in as \"ducking\" user with \"ducking\" roles to eCommerce\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}