#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "I'm logged in as (?:a\s|an\s)(?:"([^"]*)"\s)?(?:user|customer)\s(?:(?:for[\sa\s|\san\s]?)(?:"([^"]*)"\s))?"
Local $sString = "Given I'm logged in as a user for a "password change" to eCommerce" & @CRLF & _
"Given I'm logged in as an "inactive" user for a "password change" to eCommerce" & @CRLF & _
"Given I'm logged in as an "inactive" user to eCommerce" & @CRLF & _
"Given I'm logged in as a "simple" user to eCommerce" & @CRLF & _
"Given I'm logged in as a user in a "shared" account to eCommerce" & @CRLF & _
"Given I'm logged in as a user in a "bucket" account to eCommerce" & @CRLF & _
"Given I'm logged in as a user for "email notification tests" to eCommerce" & @CRLF & _
"Given I'm logged in as a user with "cs admin and sales admin" roles to eCommerce" & @CRLF & _
"Given I'm logged in as a user with "cs & bb" roles for a "passwd change" to eCommerce" & @CRLF & _
"Given I'm logged in as an "inactive" user with "cs admin" roles to eCommerce" & @CRLF & _
"" & @CRLF & _
"Given I'm logged in as "ducking" user with "ducking" roles to eCommerce" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")