const regex = /I'm logged in as (?:a\s|an\s)(?:"([^"]*)"\s)?(?:user|customer)\s(?:(?:for[\sa\s|\san\s]?)(?:"([^"]*)"\s))?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('I\'m logged in as (?:a\\s|an\\s)(?:"([^"]*)"\\s)?(?:user|customer)\\s(?:(?:for[\\sa\\s|\\san\\s]?)(?:"([^"]*)"\\s))?', 'g')
const str = `Given I'm logged in as a user for a "password change" to eCommerce
Given I'm logged in as an "inactive" user for a "password change" to eCommerce
Given I'm logged in as an "inactive" user to eCommerce
Given I'm logged in as a "simple" user to eCommerce
Given I'm logged in as a user in a "shared" account to eCommerce
Given I'm logged in as a user in a "bucket" account to eCommerce
Given I'm logged in as a user for "email notification tests" to eCommerce
Given I'm logged in as a user with "cs admin and sales admin" roles to eCommerce
Given I'm logged in as a user with "cs & bb" roles for a "passwd change" to eCommerce
Given I'm logged in as an "inactive" user with "cs admin" roles to eCommerce
Given I'm logged in as "ducking" user with "ducking" roles to eCommerce
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}