package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`I'm logged in as (?:a\s|an\s)(?:"([^"]*)"\s)?(?:user|customer)\s(?:(?:for[\sa\s|\san\s]?)(?:"([^"]*)"\s))?`)
var str = `Given I'm logged in as a user for a "password change" to eCommerce
Given I'm logged in as an "inactive" user for a "password change" to eCommerce
Given I'm logged in as an "inactive" user to eCommerce
Given I'm logged in as a "simple" user to eCommerce
Given I'm logged in as a user in a "shared" account to eCommerce
Given I'm logged in as a user in a "bucket" account to eCommerce
Given I'm logged in as a user for "email notification tests" to eCommerce
Given I'm logged in as a user with "cs admin and sales admin" roles to eCommerce
Given I'm logged in as a user with "cs & bb" roles for a "passwd change" to eCommerce
Given I'm logged in as an "inactive" user with "cs admin" roles to eCommerce
Given I'm logged in as "ducking" user with "ducking" roles to eCommerce
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}