import Foundation
let pattern = #"facebook\.com\/(?:photo.php\?v=|video\/embed\?video_id=|v\/?)(\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
https://www.facebook.com/photo.php?v=0123456789&set=t.674367&type=3&theater
http://www.facebook.com/video/embed?video_id=0123456789
http://www.facebook.com/v/0123456789
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)