#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)facebook\.com\/(?:photo.php\?v=|video\/embed\?video_id=|v\/?)(\d+)"
Local $sString = "https://www.facebook.com/photo.php?v=0123456789&set=t.674367&type=3&theater" & @CRLF & _
"http://www.facebook.com/video/embed?video_id=0123456789" & @CRLF & _
"http://www.facebook.com/v/0123456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")