package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)facebook\.com\/(?:photo.php\?v=|video\/embed\?video_id=|v\/?)(\d+)`)
var str = `https://www.facebook.com/photo.php?v=0123456789&set=t.674367&type=3&theater
http://www.facebook.com/video/embed?video_id=0123456789
http://www.facebook.com/v/0123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}