import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "facebook\\.com\\/(?:photo.php\\?v=|video\\/embed\\?video_id=|v\\/?)(\\d+)";
final String string = "https://www.facebook.com/photo.php?v=0123456789&set=t.674367&type=3&theater\n"
+ "http://www.facebook.com/video/embed?video_id=0123456789\n"
+ "http://www.facebook.com/v/0123456789";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}