using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"facebook\.com\/(?:photo.php\?v=|video\/embed\?video_id=|v\/?)(\d+)";
string input = @"https://www.facebook.com/photo.php?v=0123456789&set=t.674367&type=3&theater
http://www.facebook.com/video/embed?video_id=0123456789
http://www.facebook.com/v/0123456789";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}