re = /(
(
G(?<Gdata>\d+)
|
X(?<Xdata>\d+)
|
Y(?<Ydata>\d+)
|
Z(?<Zdata>\d+)
|
F(?<Fdata>\d+)
)
\s*
)+/
str = 'G01'
# Print the match result
str.match(re) do |match|
puts match.to_s
end