#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(" & @CRLF & _
"(" & @CRLF & _
"G(?<Gdata>\d+)" & @CRLF & _
"|" & @CRLF & _
"X(?<Xdata>\d+)" & @CRLF & _
"|" & @CRLF & _
"Y(?<Ydata>\d+) " & @CRLF & _
"|" & @CRLF & _
"Z(?<Zdata>\d+)" & @CRLF & _
"| " & @CRLF & _
"F(?<Fdata>\d+) " & @CRLF & _
")" & @CRLF & _
"\s*" & @CRLF & _
")+"
Local $sString = "G01"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")