import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\n"
+ "(\n"
+ "G(?<Gdata>\\d+)\n"
+ "|\n"
+ "X(?<Xdata>\\d+)\n"
+ "|\n"
+ "Y(?<Ydata>\\d+) \n"
+ "|\n"
+ "Z(?<Zdata>\\d+)\n"
+ "| \n"
+ "F(?<Fdata>\\d+) \n"
+ ")\n"
+ "\\s*\n"
+ ")+";
final String string = "G01";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}