$re = '/(
(
G(?<Gdata>\d+)
|
X(?<Xdata>\d+)
|
Y(?<Ydata>\d+)
|
Z(?<Zdata>\d+)
|
F(?<Fdata>\d+)
)
\s*
)+/';
$str = 'G01';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);