using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(
(
G(?<Gdata>\d+)
|
X(?<Xdata>\d+)
|
Y(?<Ydata>\d+)
|
Z(?<Zdata>\d+)
|
F(?<Fdata>\d+)
)
\s*
)+";
string input = @"G01";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}