// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(-)?([0-9]{1,3})(,)?([0-9]{1,3})?(,)?([0-9]{1,3})?(\.)([0-9]{2})").unwrap();
let string = "-11,252.40
-306.00
11,252.40
-10,946.40
306.00
-54,974.32
-55,356.82
-2,695.67
50.00
1.00
540,000.00
1,540,000.00
-11,540,000.00
-111,540,000.45
05/02
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}